1. 程式人生 > >【POJ】2796:Feel Good【單調棧】

【POJ】2796:Feel Good【單調棧】

Feel Good
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 18449   Accepted: 5125
Case Time Limit: 1000MS   Special Judge

Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 


A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 


Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input

The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 106
 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output

Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5

Source

Northeastern Europe 2005

Solution

題意:找一個區間,使這個區間最小值乘上這個區間的和最大。

用單調棧維護遞增,找出以每個$i$為最小值的最遠的左右端點即可。

每次彈棧就更新被彈元素的右端點,入棧時更新入棧元素的左端點即可。

(為什麼不把題說清楚有多組資料還有spj太垃圾了吧必須要區間最小!!!!)

(真的受不了了為什麼poj那麼卡aaaaa!!!浪費了我好多好多時間!!!!!!!!【粉轉黑!!)

Code

 

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define LL long long
using namespace std;

LL a[100005], pre[100005];
int stk[100005], R[100005], L[100005], n;
int main() {
    while(~scanf("%d", &n)) {
        int top = 0;
        memset(pre, 0, sizeof(pre));
        memset(L, 0, sizeof(L));
        memset(R, 0, sizeof(R));
        for(int i = 1; i <= n; i ++) {
            scanf("%I64d", &a[i]);
            pre[i] = pre[i - 1] + a[i];
            while(a[i] < a[stk[top]] && top) {
                R[stk[top --]] = i - 1;
            }
            L[i] = stk[top] + 1;
            stk[++ top] = i;
        }
        while(top) {
            R[stk[top --]] = n;
        }
        LL ans = 0; int l, r;
        for(int i = 1; i <= n; i ++) {
            LL tmp = (pre[R[i]] - pre[L[i] - 1]) * a[i];
            if(tmp > ans) {
                ans = tmp;
                l = L[i], r = R[i];
            }
            if(tmp == ans) {
                if(R[i] - L[i] + 1 < r - l + 1) {
                    l = L[i], r = R[i];
                }
            }
        }
        printf("%I64d\n%d %d\n", ans, l, r);
    }
    
    return 0;
}