7786 A Rational Sequence (Take 3) (遞迴)
7786 A Rational Sequence (Take 3)
An infinite full binary tree labeled by positive rational numbers is defined by:
• The label of the root is 1/1.
• The left child of label p/q is p/(p+q).
• The right child of label p/q is (p+q)/q.
The top of the tree is shown in the following figure:
:
A rational sequence is defined by doing a level order (breadth first) traversal of the tree (indicated
by the light dashed line). So that:
F (1) = 1/1, F (2) = 1/2, F (3) = 2/1, F (4) = 1/3, F (5) = 3/2, F (6) = 2/3, . . .
Write a program to compute the n-th element of the sequence, F (n). Does this problem sound
familiar? Well it should! We had variations of this problem at the 2014 and 2015 Greater NY Regionals.
Input
The first line of input contains a single integer P , (1 ≤ P ≤ 1000), which is the number of data sets
that follow. Each data set should be processed identically and independently.
Each data set consists of a single line of input. It contains the data set number, K, and the index,
N , of the sequence element to compute (1 ≤ N ≤ 2147483647).
Output
For each data set there is a single line of output. It contains the data set number, K, followed by a
single space which is then followed by the numerator of the fraction, followed immediately by a forward
slash (‘/’) followed immediately by the denominator of the fraction. Inputs will be chosen so neither
the numerator nor the denominator will overflow an 32-bit unsigned integer.ACM-ICPC Live Archive: 7786 – A Rational Sequence (Take 3)
Sample Input
4
1 1
2 4
3 11
4 1431655765
Sample Output
1 1/1
2 1/3
3 5/2
4 2178309/1346269
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <map>
using namespace std;
typedef long long ll;
struct A
{
ll num;
ll zi=0,mu=0;
};
A cc(A n)
{
if(n.num==1)
{
n.zi=1;
n.mu=1;
return n;
}
if(n.num%2==0)
{
A x;
x.num=n.num/2;
A w=cc(x);
n.zi=w.zi;
n.mu=w.zi+w.mu;
}
else
{
A x;
x.num=n.num/2;
A w=cc(x);
n.zi=w.zi+w.mu;
n.mu=w.mu;
}
return n;
}
int main()
{
int T,cnt;
cin>>T;
while(T--)
{
cin>>cnt;
cout<<cnt;
ll n;
cin>>n;
A ans;
ans.num=n;
ans=cc(ans);
cout<<" "<<ans.zi<<"/"<<ans.mu<<endl;
}
return 0;
}