1. 程式人生 > >poj刷題debug日記:poj1276(多重揹包)

poj刷題debug日記:poj1276(多重揹包)

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 39032   Accepted: 14197

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. Notes: @ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: cash N n1 D1 n2 D2 ... nN DN where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

Southeastern Europe 2002
#include<stdio.h>
#include<string.h>
int a[100005], newBills[111];
int main()
{
	int i, j, k, n, cash, index, s;
	int bills, val;
	while (~scanf("%d %d", &cash, &n)){
		memset(a, 0, sizeof(a));
		a[0] = 1;
		index = 0;
		for (i = 0; i < n; i++){
			scanf("%d %d", &bills, &val);
			k = 1;
			while (bills > 0){
				if (bills >= k){
					newBills[index] = val*k;
					bills = bills - k;
					k = k<<1;
					index++;
				} else{
					newBills[index] = val*bills;
					index++;
					break;
				}
			}
		}
		for (i = 0; i < index; i++){
			for (j = cash; j >= 0; j--){
				if (a[j] && j + newBills[i] <= cash)
					a[j+newBills[i]] = a[j];
			}
		}
		for (i = cash; i > 0; i--)
			if (a[i] != 0) break;
		printf("%d\n", i);
	}
} 

很樸素的多重揹包問題,直接轉化為01揹包問題求解會超時,於是接觸到了二進位制轉化,即把物品件數K轉化為可以表示0-K中任何一個數的若干數1, 2, 4..., 2^t, K-2^(t+1),再用01揹包求解

出現問題:

一開始一眼看到就想當然是等比數列,心想也對啊,K以下就變成lgK了,快了不少,但實際上一算還是會超時。

所以,接觸新演算法,不要想當然!!!