1. 程式人生 > >統計母音字母數

統計母音字母數

Description
輸入一行字串,統計字串中所有英文字母中的各母音字母’a/A’、‘e/E’、‘i/I’、‘o/O’、‘u/U’的個數
Input
輸入一行字串(少於80個字元),以回車結束。
Output
逐行輸出字串中各母音字母’a/A’、‘e/E’、‘i/I’、‘o/O’、'u/U’的個數。
Sample Input
There are 10 ducks.
Sample Output
1
3
0
0
1

#include<stdio.h>
int main()
{
int i=0,b=0,c=0,d=0,e=0,f=0;
char a[80];
gets(a);//gets() 函式將接收輸入的整個字串直到回車為止。
while(a[i]!=’\0’)//這是字串結束的標誌。
{
if(a[i]‘a’||a[i]

‘A’)
b++;
if(a[i]‘e’||a[i]‘E’)
c++;
if(a[i]‘i’||a[i]‘I’)
d++;
if(a[i]‘o’||a[i]‘O’)
e++;
if(a[i]‘u’||a[i]‘U’)
f++;
i++;
}
printf("%d\n%d\n%d\n%d\n%d",b,c,d,e,f);
return 0;

}