1. 程式人生 > >PAT 1084 Broken Keyboard[比較]

PAT 1084 Broken Keyboard[比較]

1084 Broken Keyboard (20 分)

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _

 (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

 題目大意:有一些鍵盤字母壞了,打不出來,現在給出原輸入和顯示的字串,判斷哪些按鍵壞掉了,並且按發現順序輸出。

//第一次提交的發現最後一個點過不去,去牛客網上提交發現以下問題:

主要是沒有考慮到,如果s2已經比對完了,但是s1中還剩下很多沒有比對,那麼剩下的那些自動就是鍵盤壞掉的。再判斷一下就可以啦。

#include <iostream>
#include <algorithm>
#include<cstdio>
#include<stdio.h>
#include <queue>
#include<cmath>
#include <vector>
#include<set>
using namespace std;

int main()
{
    string s1,s2;
    set<char> st;
    vector<char> vt;
    cin>>s1>>s2;
    int i=0;
    while(i<s1.size()&&i<s2.size()){
        if(s1[i]!=s2[i]){
            if(isalpha(s1[i])){
                s1[i]=toupper(s1[i]);
            }
            if(st.count(s1[i])==0){
                st.insert(s1[i]);
                vt.push_back(s1[i]);
            }
            //s1.substr(i,1);這樣寫不正確,s1並不會有實質性的變化。。
            //s1=s1.substr(i,1);這樣也不對,你要知道你要留下哪部分。。
            s1=s1.erase(i,1);
        }else i++;
    }
    if(i<s1.size()){
        for(int j=i;j<s1.size();j++){
            if(isalpha(s1[j])){
                s1[j]=toupper(s1[j]);
            }
            if(st.count(s1[j])==0){
                st.insert(s1[j]);
                vt.push_back(s1[j]);
            }
        }
    }
//    for(int j=0;j<st.size();j++){
//        cout<<st[i];
//    }
    for(int j=0;j<st.size();j++){
        cout<<vt[j];
    }
    return 0;
}

 

1.在set中查詢是否相同使用count函式。