1. 程式人生 > >Drying【二分】

Drying【二分】

Drying

 POJ - 3104 

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

題目大意:先輸入一個整數n,第二行輸入n個數字代表每一件衣服的水分,每件衣服每分鐘的水分都減1,第三行輸入整數k,在每一分鐘內可以選取一件衣服放到烘乾機上,烘乾機在這一分鐘內可以蒸發掉k滴水,問弄乾所有的衣服至少需要多少分鐘。

AC程式碼:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
#include <sstream>
#include <iomanip>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
int arr[maxn];
int n;
int k;
bool judge(int x)
{
	ll num=0;
	rep(i,1,n) {
		if(arr[i]<=x)
			continue;
		else
		{
			double t=arr[i]-x;
			num+=ceil(t/((double)(k-1)));
		}
	}
	if(num<=x)
		return true;
	else
		return false;
}
int main() 
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    scanf("%d",&n);
    int r=0;
    int l=0;
    rep(i,1,n) {
    	scanf("%d",&arr[i]);
    	r=max(r,arr[i]);
    }
    scanf("%d",&k);
    if(k==1)
    	printf("%d\n",r);
    else {
	    while(r-l>1) {
	    	int mid=(r+l)>>1;
	    	if(judge(mid))
	    		r=mid;
	    	else
	    		l=mid;
	    }
	    printf("%d\n",r);
	}
    return 0;
}