HDU-2199 Can you solve this equation?(二分)
Can you solve this equation?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25477 Accepted Submission(s): 10963
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output
1.6152 No solution!
http://acm.hdu.edu.cn/showproblem.php?pid=2199
題意:
給你一個Y,讓你求解8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,且x的範圍為[0,100]。如果有解,則輸出x的值,沒有解,則輸出No solution!
思路:
二分的一個簡單題,判斷左邊是否大於右邊,如果大於,則r = mid,如果小於,則l = mid,然後遞迴呼叫。
程式碼:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
double f(double mid)
{
return ((8.0 * mid * mid * mid * mid) + ((7.0 * mid * mid * mid)) + ((2.0 * mid * mid)) + 3.0 * mid + 6);
}
double con(double l, double r, double r1) {
double mid = (l+r) / 2.0;
if(r-l>0.000000001) {
if(f(mid) == r1)
return mid;
if(r1 > f(mid)) {
return con(mid, r, r1);
}
if(f(mid) > r1)
return con(l, mid, r1);
}
return mid;
}
int main()
{
int t;
cin >> t;
while(t--) {
long long y;
scanf("%lld", &y);
if(y < 6 || y > f(100)) {
cout << "No solution!" << endl;
}
else {
double l = 0, r = 100;
double r1 = (double) y;
printf("%0.4llf\n",con(l,r,r1));
}
}
return 0;
}