1032 Sharing (25 分)
1032 Sharing (25 分)
To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading
and being
are stored as showed in Figure 1.
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of i
Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Data Next
whereAddress
is the position of the node, Data
is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next
is the position of the next node.
Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1
遍歷兩次
用Java寫的 過不了......最後一個測試點執行超時所以說你改為C能過
程式碼:
import java.util.HashMap;
import java.util.HashSet;
import java.util.Scanner;
public class Main {
static Scanner sc = new Scanner(System.in);
static class node{
public int add , next;
public char data;
}
static node s[] = new node[100005];
static boolean vis[] = new boolean[100005];
public static void main(String[]args) {
int head1, head2,n;
head1 = sc.nextInt();
head2 = sc.nextInt();
n = sc.nextInt();
for(int i = 1 ; i <= n ; i ++)
{
node gg = new node();
gg.add = sc.nextInt();
gg.data = sc.next().charAt(0);
gg.next = sc.nextInt();
s[gg.add] = gg; //ok已經輸入進去了 其實可以是
}
while(head1 != -1) {
vis[head1] = true;
head1 = s[head1].next;
}
while(head2 != -1) {
if(vis[head2] == true) {
System.out.printf("%05d\n",head2);
System.exit(0);
}else
head2 = s[head2].next;
}
System.out.println(-1);
}
}