HDU 4595 Shaolin (c++ map)
Problem Description
Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.
Input
There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.
Output
A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.
Sample Input
3 2 1 3 3 4 2 0
Sample Output
2 1 3 2 4 2
題意:先輸入一個n,接下來有n行,每行輸入盲僧的代號和戰力,且代號都是升序給出的,每輸入一行,就代表這個盲僧要加入,當前加入的盲僧就要和在他之前加入的且戰力和他差值最小的盲僧solo一次,如果存在兩個盲僧和他的差值相同,他就選擇比自己弱的那個盲僧solo。最後要你輸出當前要加入的盲僧的id以及和他solo的老盲僧的id。
思路:就是STL中Map的使用,
map查詢時需要記錄一個key值,即map[key] = value,這裡我們把key值設為盲僧的戰鬥力,把id設為value,也就是
map[grade] = id,存入map中,它會自動按照key的值排序。再用上STL的迭代器,基本就能解決這個問題了
AC程式碼:
#include<iostream>
#include<cstdio>
#include<map>
#include<cmath>
using namespace std;
int main()
{
int n;
map<int,int> m;
while(~scanf("%d",&n)&&n)
{
int i;
int ans=0;
m[1000000000]=1;
int id,grade;
for(i=1;i<=n;i++)
{
scanf("%d%d",&id,&grade);
m[grade]=id;
map<int,int> ::iterator temp; //定義temp為iterator類的一個物件,也就是map容器上的迭代器
temp=m.find(grade);
if(temp==m.begin()) //如果當前的戰力是最低的,那就只能打比他戰力高的那一個
{
ans=(++temp)->second;
}
else
{
map<int,int> ::iterator temp2=temp;
if(abs((++temp)->first - grade)>=abs((--temp2)->first - grade))
{
ans=temp2->second;
}
else ans=temp->second;
}
printf("%d %d\n", id , ans);
}
m.clear(); //這步不要忘了,因為在一個程式中要輸入多次n
}
return 0;
}