1. 程式人生 > >1051 Pop Sequence (25 分)

1051 Pop Sequence (25 分)

1051 Pop Sequence(25 分)
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO

解題思路:
模擬棧的輸入,判斷時候是合法的輸出序列。
先把輸入的序列接收進陣列vi。然後按順序1~n把數字進棧,每進入一個數字,判斷有沒有超過最大範圍,超過了就break。如果沒超過,設cur = 1,從陣列的第一個數字開始,看看是否與棧頂元素相等,while相等就一直彈出棧,不相等就繼續按順序把數字壓入棧~~~最後根據變數flag的bool值輸出yes或者no。

#include<cstdio>
#include<stack>
#include<vector>
using namespace std;

int main(){
    int n,m,k;
    scanf("%d %d %d",&m,&n,&k);
    for(int i=0;i<k;i++) {
        bool flag=false;
        stack<int>st;
        vector<int>vi(n+1);
        for(int j=1;j<=n;j++){
            scanf("%d",&vi[j]);
        }
        int cur=1;
        for(int j=1;j<=n;j++){
            st.push(j) ;
            if(st.size() >m) break;
            while(!st.empty()&&st.top() ==vi[cur] ){
                st.pop() ;
                cur++;
            }
        }
        if(cur==n+1) flag=true;
        if(flag==true) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
  
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30