【笨方法學PAT】1051 Pop Sequence (25 分)
一、題目
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
二、題目大意
有個容量限制為m的棧,分別把1,2,3,…,n入棧,給出一個系列出棧順序,問這些出棧順序是否可能。
三、考點
棧
四、注意
1、注意以進棧順序為主迴圈;
2、參考:https://www.liuchuo.net/archives/2232。
五、程式碼
#include<iostream>
#include<stack>
#include<vector>
using namespace std;
int main() {
//read
int m, n, k;
cin >> m >> n >> k;
//solve
while (k--) {
bool flag = true;
int num = 1;
stack<int> sta;
vector<int> vec(n+1);
for (int i = 1; i <= n; ++i) {
cin >> vec[i];
}
for (int i = 1; i <= n; ++i) {
sta.push(i);
if (sta.size() > m) {
break;
}
while (!sta.empty() && sta.top() == vec[num]) {
sta.pop();
num++;
}
}
//output
if (num != n+1)
cout << "NO" << endl;
else
cout << "YES" << endl;
}
system("pause");
return 0;
}