hdu 6075 Questionnaire【貪心】
Questionnaire
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1204 Accepted Submission(s): 800
Special Judge
Problem Description
In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training.
Picture from Wikimedia Commons
Obviously many people don't want more training, so the clever leader didn't write down their words such as ''Yes'' or ''No''. Instead, he let everyone choose a positive integer ai to represent his opinion. When finished, the leader will choose a pair of positive interges m(m>1) and k(0≤k<m), and regard those people whose number is exactly k modulo m as ''Yes'', while others as ''No''. If the number of ''Yes'' is not less than ''No'', the leader can have chance to offer more training.
Please help the team leader to find such pair of m and k.
Input
The first line of the input contains an integer T(1≤T≤15), denoting the number of test cases.
In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of people in the ACM/ICPC team.
In the next line, there are n distinct integers a1,a2,...,an(1≤ai≤109), denoting the number that each person chosen.
Output
For each test case, print a single line containing two integers m and k, if there are multiple solutions, print any of them.
Sample Input
1
6
23 3 18 8 13 9
Sample Output
5 3
Source
2017 Multi-University Training Contest - Team 4
Recommend
liuyiding | We have carefully selected several similar problems for you: 6447 6446 6445 6444 6443
題意:
給你n個數,找出一對數m,k,滿足這a[i]%m==k的個數大於等於a[i]%m!=k,輸出任意一種答案
分析:
判斷這n個數偶數和奇數的個數,選擇%2之後餘為1還是0,若偶數多k為0,否則為1
程式碼:
#include<bits/stdc++.h>
#define ll long long
#define mod 1000000007
using namespace std;
int a[100005];
int main()
{
int t,n,i,j,aa,bb,x;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
aa=bb=0;
for(i=0;i<n;i++)
{
scanf("%d",&x);
if(x%2)
aa++;
else
bb++;
}
if(aa>=bb)
i=1;
else
i=0;
printf("2 %d\n",i);
}
}