1. 程式人生 > >POJ 3692 - Kindergarten (最大團)

POJ 3692 - Kindergarten (最大團)

Kindergarten

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 7658   Accepted: 3777

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ MG × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M

lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

題意:

      一群男生互相認識,一群女生互相認識,還有一些男生認識一些女生。現在要找出一些人,他們都互相認識,求可以找出的人的最大數。

思路:

       就是求最大團(最大完全子圖)中頂點的個數,最大完全子圖=原圖的補圖的最大獨立數。

       最大獨立數=頂點數 - 最大匹配數。

程式碼:

#include<stdio.h>
#include<string.h>
int map[210][210],book[210],match[210];
int n,m,k;
int dfs(int u)
{
	int i;
	for(i=1;i<=m;i++)
	{
		if(book[i]==0&&map[u][i]==1)
		{
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,a,b,sum,c=1;
	while(scanf("%d%d%d",&n,&m,&k)!=EOF)
	{
		if(m==0&&n==0&&k==0)
			break;
		memset(book,0,sizeof(book));
		memset(match,0,sizeof(match));
		memset(map,0,sizeof(map));
		sum=0;
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				map[i][j]=1;
		for(i=1;i<=k;i++)
		{
			scanf("%d%d",&a,&b);
			map[a][b]=0;        //存的是原圖的補圖
		}
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
				book[j]=0;
			if(dfs(i))
				sum++;
		}
		printf("Case %d: %d\n",c++,n+m-sum);  //補圖中的最大獨立集=最大完全子圖
	}
	return 0;
}