模擬_1014 Waiting in Line (30 分)
1014 Waiting in Line (30 分)
Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:
- The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
- Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
- Customeri will take Ti minutes to have his/her transaction processed.
- The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.
For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.
At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).
The next line contains K positive integers, which are the processing time of the K customers.
The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.
Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM
where HH
is in [08, 17] and MM
is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry
instead.
Sample Input:
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output:
08:07
08:06
08:10
17:00
Sorry
題目中有一個地方需要特別注意:如果開始提供服務的時間在17:00之前,是可以辦理的,不管最後時間有沒有超過17:00
並不是,在服務過程中超過17:00,就會被終止
剩下的就是剩模擬整個過程了
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;
typedef long long ll;
const int maxn = 1010;
int n,m,k,q,T[maxn],Q[maxn],line_cap[25],ans[maxn];
struct Win
{
int id,endtime,person;
bool operator < (const Win & a)const
{
if(endtime == a.endtime)
return id > a.id;
return endtime > a.endtime;
}
};
queue<int> line_que[25];
priority_queue<Win> pri_que;
void print(int x)
{
if(ans[x] == 0)
printf("Sorry\n");
else
printf("%02d:%02d\n",ans[x]/60+8,ans[x]%60);
}
int main()
{
int per = 1,num = 0;
Win win;
scanf("%d%d%d%d",&n,&m,&k,&q);
for(int i =1 ;i <= k;i ++) scanf("%d",T+i);
for(int i = 1;i <= q;i ++) scanf("%d",Q+i);
for(int i = 1;i <= k;i ++)
{
int index = i%n; if(index == 0) index = n;
if(line_que[index].size() < m)
{
line_que[index].push(i);per++;line_cap[index] ++;
}
}
for(int i = 1;i <= n;i ++)
{
win.id = i,win.person = line_que[i].front(),win.endtime = T[win.person];
pri_que.push(win);
}
while(!pri_que.empty())
{
win = pri_que.top();pri_que.pop();
num ++;
// cout <<"視窗號:"<< win.id<<" 人編號:"<<win.person <<" 結束時間"<<win.endtime<<endl;
ans[win.person] = win.endtime;
line_que[win.id].pop();
if(per <= k)
line_que[win.id].push(per++);
if(num < k && !line_que[win.id].empty() && win.endtime < 540)
{
// cout << "人編號; "<<per<<" 進入視窗:"<<win.id<<endl;
win.person = line_que[win.id].front();
win.endtime += T[win.person];
pri_que.push(win);
}
}
for(int i = 1;i <= q;i ++)
print(Q[i]);
return 0;
}