1. 程式人生 > >1014 Waiting in Line (30 分)

1014 Waiting in Line (30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

     對於排隊的題,我們用 優先佇列,來儲存每個隊伍的空閒情況,對於還線上外的人,就可以直接拿到 優先佇列的 top()位置就好了。 用來區分誰還線上外。

    對於時間來說,我們可以列舉每個時間點,因為一個時間點 一個隊最多隻有一個人完成,所以還是比較好模擬的。

 

   一開始以為所有在 17.00之前沒有服務完的,感覺都得是sorry, 後面想一下,對於那些17.00正在服務中的,我們不能趕人家走啊,對不對,所以他們必須被服務完才可以走。

 

#include<bits/stdc++.h>
using namespace std;

typedef long long LL;

#define rep(i,a,b) for(int i=a;i<b;++i)

const int N=1010;
struct Person {
    int ed;
} stu[N];

int tim[N],emp[N];
int ti[N];
queue<int> q[N];

struct node {
    int id,num;
    node(int _id=0,int _num=0)
    {
        id=_id,num=_num;
    }
    bool operator<(const node& b)const
    {
        if(num==b.num)
            return id>b.id;
        return num<b.num;
    }
};
priority_queue<node> pq;
int n,m,c,T;
void init()
{
    for(int i=0; i<n; i++) {
        emp[i]=m;
        pq.push(node(i,m));
    }
}

int main()
{
    scanf("%d %d %d %d",&n,&m,&c,&T);

    init();
    rep(i,1,c+1) {
        scanf("%d",&tim[i]);
        ti[i]=tim[i];
        
        stu[i].ed=-1;
    }
    //rep(i,1,n+1)emp[i]=1;

    int t=0,index=1;
    while(index<=c&&!pq.empty()) {
        node tmp=pq.top();
        pq.pop();
       // printf("**tmp:%d %d\n",tmp.id,tmp.num);

        q[tmp.id].push(index);
        emp[tmp.id]--;

        if(emp[tmp.id]) {
            pq.push(node(tmp.id,emp[tmp.id]));
        }
        //printf("**%d\n",pq.size());
        index++;
    }

    int st=480;
    for(int i=480; i<1020; i++) {
        for(int j=0; j<n; j++) {
            int sz=q[j].size();
            if(!sz) {
                pq.push(node(j,m));
            }else {
                int t=q[j].front();
                tim[t]--;
                if(i==1019){
                	stu[t].ed=i+1+tim[t];
				}
                if(tim[t]==0) {
					//printf("**t:%d %d %d\n",t,i+1,j);
                    stu[t].ed=i+1;
                    
                    q[j].pop();
                    emp[j]++;
                    
                    pq.push(node(j,emp[j]));
                }
            }
        }
       // printf("sz:%d\n",pq.size());
        while(index<=c&&!pq.empty()) {
            node tmp=pq.top();
            pq.pop();
            if(tmp.num&&index<=c) {
                tmp.num--;
                
                emp[tmp.id]--;
                q[tmp.id].push(index);
              //  printf("i:%d id:%d index:%d\n",i,tmp.id,index);
                index++;
                
                if(emp[tmp.id]){
					pq.push(node(tmp.id,tmp.num));
                }
            }
        }
    }

    rep(kase,0,T) {
        int t;
        scanf("%d",&t);
        if(stu[t].ed==-1) {
            printf("Sorry\n");
        } else {
            printf("%02d:%02d\n",stu[t].ed/60,stu[t].ed%60);
        }
    }

    return 0;
}