1. 程式人生 > >HDU1896 Stones【模擬+優先佇列】

HDU1896 Stones【模擬+優先佇列】

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4394    Accepted Submission(s): 2888


 

Problem Description

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 

 

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

 

Output

Just output one line for one test case, as described in the Description.

 

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12

Author

Sempr|CrazyBird|hust07p43

 

Source

HDU 2008-4 Programming Contest

問題連結:HDU1896 Stones

問題描述:Sempr在一條直線上從左往右走,在他遇到第奇數塊石頭時,他會將其往前面扔,能扔多遠在輸入中會給出,而遇到第偶數個石頭時不進行處理。當有

兩個石頭在同一位置時,則先處理"射程"(能扔的距離最短)的石頭,然後Sempr一直往前走,直到前面已經沒有任何石頭時,這時候計算Sempr與出發點的距離。對於樣例1的分析:一開始的時候遇到的是第一個石頭,他的座標是1,然後往前扔了5個單位之後,座標變成6,隨後繼續往前走,開始遇到第二個石頭(座標是2),忽略,然後繼續往前走,又遇到了原來的第一個石頭(現在是第三個石頭),但是它此時座標為6,往前扔了5個單位之後,座標變成11,然後繼續往前走,一直走在座標11時,這時候他遇到的是第四個石頭,因此忽略不計。至此,前面已經沒有石頭了,因此此時離座標原點的距離為11。

解題思路:使用優先佇列進行模擬,具體看程式。

AC的C++程式:

#include<iostream>
#include<queue>

using namespace std;

struct Node{
	int pos,dist;
	Node(){}
	Node(int pos,int dist):pos(pos),dist(dist){}
	bool operator <(const Node &a)const
	{
		return pos==a.pos?(dist>a.dist):(pos>a.pos);//如果位置一樣丟擲距離近的石頭排在前面,否則返回位置靠前的 
	}
};

int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		priority_queue<Node>q;
		scanf("%d",&n);
		int pos,dist;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&pos,&dist);
			q.push(Node(pos,dist));
		}
		//進行模擬
		bool flag=true;//是否進行處理,只對第奇數個進行處理 
		Node f;
		while(!q.empty())
		{
			f=q.top();
			q.pop();
			if(flag)
			{
				f.pos+=f.dist;
				q.push(f); 
			}
			flag=!flag;//轉變 
		}
		printf("%d\n",f.pos); 
	}
	return 0;
}