1. 程式人生 > >Commando War_UVA 11729

Commando War_UVA 11729

題目

“Waiting for orders we held in the wood, word from the front never came By evening the sound of the gunfire was miles away Ah softly we moved through the shadows, slip away through the trees Crossing their lines in the mists in the fields on our hands and our knees And all that I ever, was able to see The fire in the air, glowing red, silhouetting the smoke on the breeze” There is a war and it doesn’t look very promising for your country. Now it’s time to act. You have a commando squad at your disposal and planning an ambush on an important enemy camp located nearby. You have N soldiers in your squad. In your master-plan, every single soldier has a unique responsibility and you don’t want any of your soldier to know the plan for other soldiers so that everyone can focus on his task only. In order to enforce this, you brief every individual soldier about his tasks separately and just before sending him to the battlefield. You know that every single soldier needs a certain amount of time to execute his job. You also know very clearly how much time you need to brief every single soldier. Being anxious to finish the total operation as soon as possible, you need to find an order of briefing your soldiers that will minimize the time necessary for all the soldiers to complete their tasks. You may assume that, no soldier has a plan that depends on the tasks of his fellows. In other words, once a soldier begins a task, he can finish it without the necessity of pausing in between. Input There will be multiple test cases in the input file. Every test case starts with an integer N (1 ≤ N ≤ 1000), denoting the number of soldiers. Each of the following N lines describe a soldier with two integers B (1 ≤ B ≤ 10000) & J (1 ≤ J ≤ 10000). B seconds are needed to brief the soldier while completing his job needs J seconds. The end of input will be denoted by a case with N = 0. This case should not be processed. Output For each test case, print a line in the format, ‘Case X: Y ’, where X is the case number & Y is the total number of seconds counted from the start of your first briefing till the completion of all jobs. Sample Input 3 2 5 3 2 2 1 3 3 3 4 4 5 5 0 Sample Output Case 1: 8 Case 2: 15

 題目大意

你是一名將軍,你需要向每一名士兵介紹任務,然後士兵去完成任務

介紹和完成任務都需要話費時間,在前一個士兵去進行任務的同時,你可以給下一名士兵介紹任務

求最小介紹+完成任務時間

演算法:貪心 

程式碼

#include<iostream>
#include<algorithm>
using namespace std;
struct war
{
	int b,j;
	bool operator<(const war& a)const
	{
		return j>a.j;
	}
}a[10000];
int main()
{
	int n;int num=0;
	while(cin>>n&&n)
	{
		for(int i=0;i<n;i++)
			cin>>a[i].b>>a[i].j; 
		sort(a,a+n);
		int ans,t;
		ans=0,t=0;
		for(int x=0;x<n;x++)
		{
			t+=a[x].b;          //這次開始工作的時間
			ans=max(ans,t+a[x].j);  //比較這次開始工作的時間+這次工作所需時間(也就是完成這次工作的總時間) 與 之前的時間 
		}
		cout<<"Case "<<++num<<": "<<ans<<endl;
	}
	
	return 0;
}
//貪心 先執行完成任務時間長的 這樣在他完成任務的同時 可以給別人安排
//每個任務開始的時間肯定是 t+a[x]b 之前的介紹時間+這次的介紹時間
//比較這次開始工作的時間+這次工作所需時間(也就是完成這次工作的總時間) 與 之前的時間 
//然後取較大的那一個,如果取較小值,那麼這個工作就無法完成