1. 程式人生 > >Commando War ,UVa 11729

Commando War ,UVa 11729

【題目】
There is a war and it doesn’t look very promising for your country. Now it’s time to act. You have a commando squad at your disposal and planning an ambush on an important enemy camp
located nearby. You have N soldiers in your squad. In your master-plan, every single soldier has a
unique responsibility and you don’t want any of your soldier to know the plan for other soldiers so that
everyone can focus on his task only. In order to enforce this, you brief every individual soldier about
his tasks separately and just before sending him to the battlefield. You know that every single soldier
needs a certain amount of time to execute his job. You also know very clearly how much time you
need to brief every single soldier. Being anxious to finish the total operation as soon as possible, you
need to find an order of briefing your soldiers that will minimize the time necessary for all the soldiers
to complete their tasks. You may assume that, no soldier has a plan that depends on the tasks of his
fellows. In other words, once a soldier begins a task, he can finish it without the necessity of pausing
in between.
【Input】
There will be multiple test cases in the input file. Every test case starts with an integer N (1 ≤
N ≤ 1000), denoting the number of soldiers. Each of the following N lines describe a soldier with two
integers B (1 ≤ B ≤ 10000) & J (1 ≤ J ≤ 10000). B seconds are needed to brief the soldier while
completing his job needs J seconds. The end of input will be denoted by a case with N = 0. This case
should not be processed.
【Output】
For each test case, print a line in the format, ‘Case X: Y ’, where X is the case number & Y is the
total number of seconds counted from the start of your first briefing till the completion of all jobs.
【Sample Input】
3
2 5
3 2
2 1
3
3 3
4 4
5 5
0
【Sample Output】
Case 1: 8
Case 2: 15
【題解】
使用貪心演算法,執行時間長的先交代,按照J從大到小的順序給各個任務排序,然後依次交代。

#include <cstdio>
#include <vector>
#include <algorithm>

using namespace std;

struct Job {
    int j, b;

    bool operator<(const Job &x) const {             //運算子過載
        return j > x.j;
    }
};

int main() {
    int n, b, j, kase = 1;
    while (scanf("%d", &n) == 1
&& n) { vector<Job> v; for (int i = 0; i < n; i++) { scanf("%d%d", &b, &j); v.push_back((Job) {j, b}); } sort(v.begin(), v.end()); //使用Job類自己的<運算子排序 int s = 0; int ans = 0; for (int i = 0
; i < n; i++) { s += v[i].b; //當前任務的開始執行時間 ans = max(ans, s + v[i].j); //更新任務執行完畢時的最晚時間 } printf("Case %d: %d\n", kase++, ans); } return 0; }