poj-3292
This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.
An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only
As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H
For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.
Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H
Input
Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.
Output
For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.
Sample Input
21 85 789 0
Sample Output
21 0 85 5 789 62
#include <stdio.h>
#include <math.h>
#define max 1000001
int a[1000001]={0};
int main()
{
int i,j,temp;//temp 控制上限
int k,l;
for(i=5;i<=max;i+=4)
{
for(j=5;j<=max;j+=4)
{
temp=i*j;
if(temp>max)break;
if(!a[i]&&!a[j]) //將所有 非 "質數" 乘機的數 化為 -1 也就是 排除 出H-semi-prime
a[i*j]=1;
else
a[i*j]=-1;
}
}
int g,t=0;
for(i=1;i<=1000001;i++)// 再次打表,將所有 H-semi-prime 個數 記錄 下來 否則易超時
{
if(a[i]==1)
t++;
a[i]=t;
}
scanf("%d",&g);
while(g)
{
printf("%d %d\n",g,a[g]);
scanf("%d",&g);
}
return 0;
}