1. 程式人生 > >POJ 3292

POJ 3292

Semi-prime H-numbers

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11042 Accepted: 4978

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H

-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H

-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H

-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62

Source

大致題意:

H=4*N(正整數)+1

而在H組成的數字中,若H除了其本身*1之外,可以由其餘兩個H數字相乘得到的話,則稱為H-composite,反之則稱為H-prime

兩個H-prime相乘得到的H數稱為H-semi-prime

給定一個H數hh,求1-hh之間的H-semi-prime個數

解題思路:

由於hh範圍為5-1000001,所以用INT表示,並且直接進行預處理打表即可,由h[i]表示小於i的h-semi-prime個數

首先由規律得知,兩個H相乘乘積也是H數

(4i+1)*(4j+1)=16ij+4(i+j)+1

所以直接迴圈,標誌出h-semi-prime,最後計數即可。

程式碼:

#include <iostream>
#include <cmath>
#include <cstring>
using namespace std;
int h[1000001];
void hprime()
{
	h[1000001]={0};
	//i*j=素數*素數
	//若h[i]=0,說明i沒有除了i*1之外的方法得到,是h-prime
    //同理j也是h-prime,i*j=h-semi-prime
    for(int i=5;i<=1000001;i+=4)//h1 
    for(int j=5;j<=1000001;j+=4)//h2
    {	
    	if(i*j>1000001)
    	break;
    	else
    	{
    		if(h[i]==0&&h[j]==0) 
    		{
    			h[i*j]=1;//h-prime*h-prime
			}
			else
			h[i*j]=-1;//h-copo 
		}
	}
	int count=0;
	for(int i=0;i<=1000001;i++)
	{
		if(h[i]==1)
		{
			count++;
		}
		h[i]=count;
	} 
}
int main()
{ 
    hprime();
    int hh;
	while(cin>>hh&&hh)
	{
	cout<<hh<<" "<<h[hh]<<endl;
    }
	
	return 0;
 }