1. 程式人生 > >Silver Cow Party POJ

Silver Cow Party POJ

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai

to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

題意:n個城市,m條道路,要將物品從1城市運送到n城市,求在從1到n的路徑中每條路徑中道路最小值的最大值。

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;
const int maxn = 100100;
const int inf = 0x3f3f3f3f;
int dis[maxn],inque[maxn],head[maxn],n,m,tot;

struct node
{
    int v;
    int next;
    int w;
}edg[maxn];

void addnode(int u,int v,int w)
{
    edg[tot].v = v;
    edg[tot].w = w;
    edg[tot].next = head[u];
    head[u] = tot++;
}

void SPFA()
{
    queue<int>Q;
    Q.push(1);
    inque[1] = 1;
    dis[1] = inf;//要初始化為無窮大

    while(!Q.empty())
    {
        int u = Q.front();
        Q.pop();
        inque[u] = 0;
        for(int i = head[u];i != -1;i = edg[i].next)
        {
            int v = edg[i].v,w = edg[i].w;
            if(dis[v] < min(dis[u],w))
            {
                dis[v] = min(dis[u],w);
                if(!inque[v])
                {
                    Q.push(v);
                    inque[v] = 1;
                }
            }
        }
    }
}

int main()
{
    int t;
    int cas = 0;
    scanf("%d",&t);
    while(t--)
    {
        tot = 0;
        memset(head,-1,sizeof(head));
        memset(dis,0,sizeof(dis));

        scanf("%d %d",&n,&m);
        for(int i = 1;i <= m;i++)
        {
            int u,v,w;
            scanf("%d %d %d",&u,&v,&w);
            addnode(u,v,w);
            addnode(v,u,w);
        }

        SPFA();

        printf("Scenario #%d:\n",++cas);
        printf("%d\n\n",dis[n]);
    }
    return 0;
}