【HDU 3555】Bomb(數位dp)
Bomb Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others) Total Submission(s): 23401 Accepted Submission(s): 8811
Problem Description The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point. Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
The input terminates by end of file marker.
Output For each test case, output an integer indicating the final points of the power.
Sample Input
3 1 50 500
Sample Output
0 1 15
Hint From 1 to 500, the numbers that include the sub-sequence “49” are “49”,”149”,”249”,”349”,”449”,”490”,”491”,”492”,”493”,”494”,”495”,”496”,”497”,”498”,”499”, so the answer is 15.
Author [email protected]
Source 2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU
研究了好久的數位dp,現在基本上入門了,什麼是數位dp,數位dp就是在數位上面進行的動態規劃,一般情況下都是利用DFS+記憶化來進行狀態轉移的 我們在DFS的時候一般會傳遞三個變數:pos(位置),sta(狀態),limit(是否達到上限)。
#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e6+10;
const int INF = 0x3f3f3f3f;
typedef int INT;
#define int long long
int digit[200];
int dp[30][2];
int dfs(int pos,bool if4,bool limit){
if(pos==0) return 1;
if(!limit&&dp[pos][if4]) return dp[pos][if4];
int ans=0;
int up=(limit?digit[pos]:9);
for(int i=0;i<=up;i++){
if(if4&&i==9) continue;
ans+=dfs(pos-1,i==4,limit&&i==up);
}
if(!limit) dp[pos][if4]=ans;
return ans;
}
int solve(int x){
int cnt=0;
while(x){
digit[++cnt]=x%10;
x/=10;
}
return dfs(cnt,0,1);
}
INT main(){
int t,n;
cin>>t;
while(t--){
cin>>n;
cout<<n-solve(n)+1<<endl;
}
return 0;
}