1103 Integer Factorization(PAT 甲等 C++實現)
1103 Integer Factorization (30 point(s))
The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.
Input Specification:
Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.
Output Specification:
For each case, if the solution exists, output in the format:
N = n[1]^P + ... n[K]^P
where n[i]
(i
= 1, ..., K
) is the i
-th factor. All the factors must be printed in non-increasing order.
Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122+42+22+22+12, or 112+62+22+22+22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1,a2,⋯,aK } is said to be larger
If there is no solution, simple output Impossible
.
Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
分析:
本題是用到圖的深度優先遍歷演算法。
把從 1 到底數最大值存放 factor 動態陣列中。
從而把問題轉化為,在 factor 數組裡面選 K 個數相加等於N,即多對多關係(圖)。
而找這 K 個數即通過圖的深度優先遍歷來找到最優的底數系列。
詳細程式碼:
#include <iostream>
#include <algorithm>
#include <math.h>
#include <vector>
using namespace std;
int n,k,p;
int maxfacsum=-1;
vector<int> factor,ans,temp;
static void DFS(int index,int nowk,int sum,int facsum){
if(sum==n && nowk==k){ // 條件滿足
if(facsum > maxfacsum){
ans = temp;
maxfacsum = facsum;
}
return;
}
if(sum>n || nowk>k){ // 不符合要求
return;
}
if(index-1>=0){
temp.push_back(index);
DFS(index,nowk+1,sum+factor[index],facsum+index);
temp.pop_back();
DFS(index-1,nowk,sum,facsum);
}
}
// 1103 Integer Factorization (30 point(s))
int main(void){
cin>>n>>k>>p;
int temp=0,j=0;
while(temp<=n){ //存放 P(2~7) 即底數肯定小於 factor.size()
factor.push_back(temp);
temp = pow(++j,p);
}
DFS(factor.size()-1,0,0,0); // 深度優先遍歷
if(maxfacsum == -1){ // 輸出
cout<<"Impossible"<<endl;
}else{
cout<<n<<" = "<<ans[0]<<"^"<<p;
for(int i=1;i<ans.size();++i){
cout<<" + "<<ans[i]<<"^"<<p;;
}
}
return 0;
} // jinzheng 2018.9.19 15:33