1. 程式人生 > >1155 Heap Paths (30 分)

1155 Heap Paths (30 分)

1155 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at

https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

可以廣搜輸出層序當然也可以廣搜簡歷層序啊

還有深搜輸出那些點。。。烏拉

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<queue>
using namespace std;
struct node
{
	int data;
	struct node *left, *right;
};
int n,x;
struct node* root = NULL;
vector<int>vec;
void init() //層序建立一個樹。。。這邊容易判斷是否是大小堆 
{
	int m = n - 1;
	scanf("%d", &x);
	root = new node();
	root->data = x;
	root->left = root->right = NULL;
	queue<node*>qu;
	qu.push(root);
	while(qu.empty() == 0 && m > 0)
	{
		struct node*tmp = qu.front();
		qu.pop();
		if(m > 0)
		{
			scanf("%d",&x);
			struct node*kk = new node();
			kk->data = x;
			kk->left = kk->right = NULL;
			tmp->left = kk;
			m--;
			qu.push(kk);
		}
		if(m > 0)
		{
			scanf("%d",&x);
			struct node*kk = new node();
			kk->data = x;
			kk->left = kk->right = NULL;
			tmp->right = kk;
			m--;
			qu.push(kk);
		}
	}
	return ;
}
void DFS(struct node* tree)
{
	if(tree->left == NULL && tree->right == NULL)
	{
		int num = vec.size();
		for(int i = 0 ; i < num; i ++)
			printf("%d%c",vec[i]," \n"[i == num-1]);
		return;
	}
	if(tree->right != NULL){
		vec.push_back(tree->right->data);
		DFS(tree->right);	
		vec.pop_back();
	}
	if(tree->left != NULL){
		vec.push_back(tree->left->data);
		DFS(tree->left);	
		vec.pop_back();
	}
}
//這邊規定下 最大堆為1  最小堆為-1  不倫不類為0; 
int check(struct node*gg)
{
	if(n == 2)
	{
		if(gg->left)
		{
			if(gg->data > gg->left->data)
				return 1;
			else 
				return -1;
		}
		if(gg->right)
		{
			if(gg->data > gg->right->data)
				return 1;
			else 
				return -1;
		}
	}
	queue<node*>qu;
	qu.push(gg);
	int l, r;
	if(gg->left)
	{
		if(gg->data > gg->left->data)
			l = 1;
		else 
			l = -1;
	}
	if(gg->right)
	{
		if(gg->data > gg->right->data)
			r = 1;
		else 
			r = -1;
	}
	if(l != r)
		return 0;
	int kk = l;//現在已經知道堆這個地方是啥了 那麼現在以下都要遵守這個 
	while(qu.empty() == 0)
	{
		struct node*tmp = qu.front();
		qu.pop();
		int dd; 
		if(tmp->left)
		{
			qu.push(tmp->left);
			if(tmp->data > tmp->left->data)
				dd = 1;
			else 
				dd = -1;
			if(dd != kk)
				return 0;
		} 
		if(tmp->right)
		{
			qu.push(tmp->right);
			if(tmp->data > tmp->right->data)
				dd = 1;
			else 
				dd = -1;
			if(dd != kk)
				return 0;	
		} 
	}
	return kk;
}

int main()
{
	scanf("%d", &n);
	init();
	vec.push_back(root->data);
	DFS(root); 
	int kk = check(root);
	if(kk == 1)
		printf("Max Heap\n");
	else if(kk == -1)
		printf("Min Heap\n");
	else 
		printf("Not Heap\n");
	return 0;
}