1. 程式人生 > >POJ 1068

POJ 1068

Parencodings

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28491 Accepted: 16786

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:  q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).  q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).  Following is an example of the above encodings: 

	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

大致題意:

一個括號表示式可以按照如下的規則表示,就是每個右括號之前的左括號數。
比如(((()()()))),每個右括號之前的左括號數序列為P=4 5 6 6 6 6,而每個右括號所在的括號內包含的括號數為W=1 1 1 4 5 6.
現在給定P,輸出W。

解題思路:

先根據P還原整個括號表示式,存在陣列中,然後遞迴解出W..

程式碼:

#include<iostream>  
using namespace std;  
char y[10000];  int p[50],w[50],n,l,j;  //y為還原後的括號
int f()  
{  
    int s=1;  //消除之前的連續左括號對結果的影響
    while(1)  
        if(y[j]=='(')  //若是左括號,繼續遞迴求解
        {  
            j++;  
            s+=f();  
        }  
        else  //若是右括號,將已有括號數寫入W
        {  
            w[l++]=s;  
            j++;  
            return s;  
        }  
}  
int main()  
{  
    int t,i,k;  
    cin>>t;  //例子個數
    while(t--)  
    {  
        cin>>n;  //右括號個數
        for(i=0,l=0,k=0;i<n;i++)  
        {  
            cin>>p[i];  //輸入P
            for(j=0;j<p[i]-k;j++)  //每個右括號前的左括號加入序列
                y[l++]='(';  
            y[l++]=')';  //加入此次右括號
            k=p[i];  //之前加過的左括號去掉,以免重複
        }  
        l=j=0;  
        f();  
        for(i=0;i<n;i++)  
            cout<<w[i]<<' ';  
        cout<<endl;  
    }  
    return 0;  
}