1. 程式人生 > >PAT甲級1012 (結構體,排序)

PAT甲級1012 (結構體,排序)

題目

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C – C Programming Language, M – Mathematics (Calculus or Linear Algebra), and E – English. At the mean time, we encourage students by emphasizing on their best ranks — that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A – Average of 4 students are given as the following:

StudentID C M E A 310101 98 85 88 90 310102 70 95 88 84 310103 82 87 94 88 310104 91 91 91 91 Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output “N/A”.

Sample Input 5 6 310101 98 85 88 310102 70 95 88 310103 82 87 94 310104 91 91 91 310105 85 90 90 310101 310102 310103 310104 310105 999999 Sample Output 1 C 1 M 1 E 1 A 3 A N/A

題解

#include<cstdio>
#include<algorithm>
using namespace std;
struct student{
  int id;
  int score[4];//每個人每門課的分數,每門課的排名
}stu[2010];

int Rank[1000000][4]={0};//初始化排名為0
int course;
bool cmp(student a,student b){
  return a.score[course]>b.score[course];
}
char k[4]={'A','C','M','E'};

int main(int argc, char *argv[]){
  int n,m;
  int q;
  scanf("%d %d",&n,&m);
  for(int i=0;i<n;i++){
    scanf("%d%d%d%d",&stu[i].id,&stu[i].score[1],&stu[i].score[2],&stu[i].score[3]);
    stu[i].score[0]=stu[i].score[1]+stu[i].score[2]+stu[i].score[3];//0A,1C,2M,3E
  }
  for(course=0;course<4;course++){//判斷哪個哪個就放外迴圈,這邊不能寫成int courese因為變數已定義,是同一變數
    sort(stu,stu+n,cmp);//分別排了4個成績的序 應該得出四個結點,而不單單是分數
    Rank[stu[0].id][course]=1;//與庫中元素重名
    for(int j=1;j<n;j++){
      if(stu[j].score[course]==stu[j-1].score[course]){
         Rank[stu[j].id][course]= Rank[stu[j-1].id][course];
      }
        
      else Rank[stu[j].id][course]=j+1;//=號右邊原來是錯誤的
    }
  }

  for(int i=0;i<m;i++){
    scanf("%d",&q);
    if(Rank[q][0]==0) printf("N/A\n");
    else{
      int temp=0;
      for(int i=0;i<4;i++){
        if(Rank[q][i]<Rank[q][temp])
          temp=i;
        //選出被查詢學生4科中排名最前的一科
      }
      printf("%d %c\n",Rank[q][temp],k[temp]);
    }
  }
  return 0;
} 

這裡犯了陣列名不能與庫函式同名,已定義的同一變數不能再宣告的錯誤。以及一開始沒有意識到結構體排序是排得結點。

以及排序到了第3個人,他應該就是第3名,而不是前面並列的名次+1。