1. 程式人生 > >HDU 5510 KMP+優化

HDU 5510 KMP+優化

HDU 5510 Bazinga

Problem Description Ladies and gentlemen, please sit up straight. Don’t tilt your head. I’m serious. 在這裡插入圖片描述

For n given strings S1,S2,⋯,Sn, labelled from 1 to n, you should find the largest i (1≤i≤n) such that there exists an integer j (1≤j<i) and Sj is not a substring of Si.

A substring of a string Si is another string that occurs in Si. For example, ruiz" is a substring of

ruizhang", and rzhang" is not a substring ofruizhang".

Input The first line contains an integer t (1≤t≤50) which is the number of test cases. For each test case, the first line is the positive integer n (1≤n≤500) and in the following n lines list are the strings S1,S2,⋯,Sn. All strings are given in lower-case letters and strings are no longer than 2000 letters.

Output For each test case, output the largest label you get. If it does not exist, output −1.

Sample Input 4 5 ab abc zabc abcd zabcd 4 you lovinyou aboutlovinyou allaboutlovinyou 5 de def abcd abcde abcdef 3 a ba ccc

Sample Output Case #1: 4 Case #2: -1 Case #3: 4 Case #4: 3

題解: 這個題的做法就是KMP演算法加一點優化,當一個字串a是字串b的連續字串時,那麼我們就可以不用再管小的這個字串a,因為如果大的字串b屬於某個字串,那麼字串a肯定也屬於這個字串,如果小的字串a不屬於某個字串,那麼字串b肯定也不屬於這個字串,所以我們只需要判定字串b即可。這樣,用一個二重迴圈,第一重i從第2個字串到n,第二重j從1開始到i-1。用KMP演算法判斷字串j是不是字串a的字串。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int vis[505],ne[2005],flag;
char str[505][2005];

void next(char *s)
{
    int i,k,len;

    len = strlen(s);
    ne[0] = -1;
    k = -1;
    for(i = 1; i < len; i++)
    {
        while(k > -1 && s[k+1] != s[i])
        {
            k = ne[k];
        }
        if(s[k+1] == s[i])
        {
            k++;
        }
        ne[i] = k;
    }
}

int kmp(char *s1,char *s2)
{
    int i,k,len1,len2;

    len1 = strlen(s1);
    len2 = strlen(s2);
    k = -1;
    next(s2);
    for(i = 0; i < len1; i++)
    {
        while(k > -1 && s2[k+1] != s1[i])
        {
            k = ne[k];
        }
        if(s2[k+1] == s1[i])
        {
            k++;
        }
        if(k == len2-1)
        {
            return 1;
        }
    }
    return 0;
}

int main()
{
    int i,j,k,t,n,ans;

    scanf("%d",&t);
    for(k = 1; k <= t; k++)
    {
        scanf("%d",&n);
        for(i = 0; i < n; i++)
        {
            scanf("%s",str[i]);
        }
        memset(vis,1,sizeof(vis));
        ans = -2;
        for(i = 1; i < n; i++)
        {
            for(j = 0; j < i; j++)
            {
                if(vis[j] != 0)
                {
                    if(kmp(str[i],str[j]) == 1)
                    {
                        vis[j] = 0;
                    }
                    else
                    {
                        ans = i;
                        break;
                    }
                }
            }
        }
        printf("Case #%d: %d\n",k,ans+1);
    }
    return 0;
}