POJ2572(Seek the Name, Seek the Fame)
阿新 • • 發佈:2018-12-12
Seek the Name, Seek the Fame
Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).
Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 14398 | Accepted: 7188 |
Description
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).
Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.Sample Input
ababcababababcabab aaaaa
Sample Output
2 4 9 18 1 2 3 4 5題意:找到字串字尾和字首相同的所有長度,並升序輸出。
思路:kmp,對kmp進一步理解即可寫出。
kmp演算法中,next [i] = k 表示第i - k + 1個元素到第 i 個元素與字串的前k位相同;那麼要統計字尾與字首相同的個數,只需在next陣列中以next [ len ](len為字串長度)為起點向前查詢即可。注意到第 i 位的字元必與 k 位的字元相同,且其前面的字元在對應位置的也一一相同,那麼令i = k的方式向前查詢,每次查詢的 k 值即為一個字尾與字首相同的長度。且查詢到的k值嚴格遞減,那麼儲存下來逆序輸出即可。
#include<cstdio>
#include<cstring>
char a[400005];
int nxt[400005],ans[400005],len;
void getnxt(){
int i = - 1, j = 0;
nxt[0]=-1;
while(j<=len){
if(i==-1||a[i]==a[j]){
nxt[++j]=++i;
}
else i=nxt[i];
}
}
int main(){
while(~scanf("%s",a)){
len=strlen(a);
memset(nxt,0,sizeof(nxt));
getnxt();
int k=0;
for(int i = nxt[len];i>0;i=nxt[i]){
ans[k++]=i;
}
for(int i =k-1; i >=0; i--){
printf("%d ",ans[i]);
}
printf("%d\n",len);
}
return 0;
}