1. 程式人生 > >hdu_3371 Connect the Cities

hdu_3371 Connect the Cities

Connect the Cities
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25092    Accepted Submission(s): 5807


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6
 

Sample Output
1
 

Author
dandelion
 

Source
HDOJ Monthly Contest – 2010.04.04
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1233 1102 1875 1301 1879 
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int MAX=55000;
struct Edge
{
	int vex1;
	int vex2;
	int weight;
}E[MAX];
int vset[MAX];
int n,m,k;
int v1,v2,dist;

void init(){
	for(int i=1;i<=n;i++)
		vset[i]=i;
	for(int i=0;i<m;i++)
	{
		scanf("%d%d%d",&v1,&v2,&dist);
		E[i].vex1=v1;
		E[i].vex2=v2;
		E[i].weight=dist;
	}
}

bool operator <(const Edge&E1,const Edge&E2)
{
	return E1.weight<E2.weight;
}

int GetParent(int i)
{
	if(vset[i]!=i)
		vset[i]=GetParent(vset[i]);
	return vset[i];
}

void kruskal(Edge E[],int m,int e)
{
	int sum=0;
	for(int j=0;j<m;j++)
	{
		int p1=GetParent(E[j].vex1);
		int p2=GetParent(E[j].vex2);
		if(p1!=p2)
		{
			sum+=E[j].weight;
			vset[p2]=p1;
			e--;
		}
	}
	if(!e)//判斷邊數是否為0,若為0則表示所有邊都找到了
		printf("%d\n",sum);
	else
		printf("-1\n");
}

int main()
{
	int c;
	scanf("%d",&c);
	while(c--)
	{
		int i;
		scanf("%d%d%d",&n,&m,&k);
		int e=n-1;//構成最小生成樹所需邊數
		init();
		
		int t,p1,p2;
		for(i=0;i<k;i++)
		{
			scanf("%d",&t);
			scanf("%d",&v1);
			p1=GetParent(v1);
			while(--t)
			{
				scanf("%d",&v2);
				p2=GetParent(v2);
				if(p1==p2)
					continue;
				vset[p2]=p1;
				e--;//聯通兩個點之後,即找到了一條生成樹的邊。所以還剩下的邊減一條。
			}
		}
		sort(E,E+m);
		kruskal(E,m,e);
	}
	return 0;
}