Bad Hair Day ——牛說我瞅你咋地——單調棧POJ3250
Bad Hair Day
Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.
Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i
Consider this example:
= = = = - = Cows facing right --> = = = = - = = = = = = = = = 1 2 3 4 5 6
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!
Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.
Input
Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Line 1: A single integer that is the sum of c 1 through cN.
Sample Input
6 10 3 7 4 12 2
Sample Output
5
題意:一群牛往右看(大概右邊有妹子 ?_? ),每頭牛可以看見右邊比他矮的,如果比他矮的牛,被比他高的牛擋到了,顯然他看不見。 所以求這些牛一共能看見多少牛?
注意: 一樣高的他也看不見。
第一感覺是單調棧,然後逆向思維一下,對於每頭牛應該考慮他被多少頭牛看見,然後建一個從左往右的單調減棧,得到答案;
題意轉換成 每頭牛能被在他左邊比他矮的看見 應該才是突破;
我也不明白 int為什麼會WA,,,
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <stack>
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
const int maxn=2e6+7;
int n,m;
int main()
{
int t;
while(scanf("%d",&n)!=EOF&&n)
{
unsigned long long cnt=0;
for(int i=1;i<=n;++i)
scanf("%d",&a[i]);
stack<int> st;
///構造一個單調減的棧 從右往左
for(int i=1;i<=n;++i)
{
while(!st.empty()&&a[i]>=st.top())
{
st.pop();
}
cnt+=st.size();
st.push(a[i]);
}
cout<<cnt<<endl;
}
return 0;
}