1. 程式人生 > >ACM--單調棧--Bad Hair Day--POJ--3250--水

ACM--單調棧--Bad Hair Day--POJ--3250--水

Bad Hair Day

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ h≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i

 can see the tops of the heads of cows in front of her (namely cowsi+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

================================華麗的分割線=============================

    單調棧的入門題:單調棧就是維護一個棧,棧中的元素都保持著單調遞增或遞減的順序。

     題目意思:有n只牛站在一排,給出隊伍中每隻牛的高度,每隻牛隻能看到它右邊比它矮的牛,求所有的牛能看到的牛數之和。
    當我們新加入一個高度值時,如果棧中存在元素小於新加入的高度值,那這個牛肯定看不見這個高度的牛,就把這個元素彈棧。

    每次加入新元素,並執行完彈出操作後,棧中元素個數便是可以看見這個牛的“牛數”。

 #include<iostream>
 #include<cstdio>
 #include<stack>
 using namespace std;
 int main(void){
     int n;
     stack <long long>sta;
     if(scanf("%d",&n)!=EOF){
       long long  result=0;
       long long  x;
         cin>>x;
       //將第一個元素入棧
       sta.push(x);
     for(int i=1;i<n;i++){
         cin>>x;
         while(!sta.empty()&&sta.top()<=x){
              sta.pop();
         }
         result+=sta.size();
         sta.push(x);
     }
       cout<<result<<endl;
       //清空棧
     while(!sta.empty()){
        sta.pop();
     }

   }

     return 0;
 }