1. 程式人生 > >HDU1028 Ignatius and the Princess III(母函式)

HDU1028 Ignatius and the Princess III(母函式)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 26149    Accepted Submission(s): 18059

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says. "The second problem is, given an positive integer N, we define an equation like this:   N=a[1]+a[2]+a[3]+...+a[m];   a[i]>0,1<=m<=N; My question is how many different equations you can find for a given N. For example, assume N is 4, we can find:   4 = 4;   4 = 3 + 1;   4 = 2 + 2;   4 = 2 + 1 + 1;   4 = 1 + 1 + 1 + 1; so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4 10 20

Sample Output

5 42 627

方法:

此題應用母函式來解決,母函式就是常常用來解決組合方面的題目。母函式相關內容講解:講解1  講解2

程式碼:

#include <iostream>
using namespace std;

int main()
{
	int result[121];
	int temp[121];
	int target;
	
	while (cin >> target)
	{
		for (int i = 0; i <= target; i++)
		{
			result[i] = 1;
			temp[i] = 0;
		}
		
		for (int k = 2; k <= target; k++)
		{
			for (int i = 0; i <= target; i++)
				for (int j = 0; j + i <= target; j += k)
					temp[i+j] += result[i];
			
			for (int i = 0; i <= target; i++)
			{
				result[i] = temp[i];
				temp[i] = 0;
			}
		}
		
		cout << result[target] << endl;
	}
	
	return 0;
}