1. 程式人生 > >POJ Cube Stacking

POJ Cube Stacking

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:  moves and counts.  * In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.  * In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.  Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P  * Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.  Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

題目大意:有N個立方體和N個格子,1~N編號,一開始i立方體在i號格子上,每個格子剛好1個立方體。現在m組操作,M a b表示將a號立方體所在的格子的全部立方體放在b號立方體所在的格子的全部立方體上面。C x表示詢問x號立方體下面的立方體的個數。  

#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;
const int N = 3e4 + 10;
int p[N];
int s[N];//代表 在這個方格的總共的立方體數
int cnt[N];//代表 i  下面的立方體數
int findth(int x)
{
	if (x != p[x]) {
		int t = p[x];
		p[x] = findth(p[x]);
		cnt[x] += cnt[t];//路徑壓縮
	}
	return p[x];
}
void unionn(int x, int y)
{
	int xx = findth(x);
	int yy = findth(y);
	if (xx != yy) {
		p[xx] = yy;
		cnt[xx] = s[yy];
		s[yy] += s[xx];
	}
}
int main()
{
	for (int i = 1;i <= N;i++) {
		p[i] = i;
		s[i] = 1;
	}
	int T;
	scanf("%d", &T);
	while (T--) {
		char t[5];
		scanf("%s", t);
		if (t[0] == 'M'){
			int x, y;
			scanf("%d %d", &x, &y);
			unionn(x, y);
		}
		else {
			int x;
			scanf("%d", &x);
			findth(x);//路徑壓縮
			printf("%d\n", cnt[x]);
		}
	}
	return 0;
}