1. 程式人生 > >poj 1988Cube Stacking(並查集路徑壓縮 求本節點到父節點的結點數)

poj 1988Cube Stacking(並查集路徑壓縮 求本節點到父節點的結點數)

Cube Stacking

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 28664 Accepted: 10067
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:  moves and counts.  * In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.  * In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.  Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P  * Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.  Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source

把下面的看成父節點,但是並查集的每個節點維護3個變數:父節點編號father[i],其與父節點之間有多少個節點(不包括當前節點但包括父節點)v[i],以當前節點為根的連通分量一共有多少節點total[i]。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 50005
int father[maxn];
int v[maxn];
int total[maxn];
using namespace std;
int find(int x)
{
    if(father[x]==x)
    return x;
    int root=find(father[x]);
    v[x]+=v[father[x]];
    return father[x]=root;

}
void unionn(int x,int y)
{
    int fa=find(x);
    int fb=find(y);
    if(fa!=fb)
    {
        father[fa]=fb;
        v[fa]=total[fb];
        total[fb]+=total[fa];
    }
}
int main()
{
    int p;
    while(~scanf("%d",&p)&&p)
    {
        for(int i=0;i<=maxn;i++)
        {father[i]=i;
        total[i]=1;
        v[i]=0;

    }
    while(p--)
    {
        char str[10];
        int a,b;
        scanf("%s",str);
        if(str[0]=='M')
        {
            scanf("%d%d",&a,&b);
            unionn(a,b);
        }
        else if(str[0]=='C')
        {
            scanf("%d",&a);
            find(a);
            printf("%d\n",v[a]);
        }
    }

}
return 0;
}