Good Bye 2017 G.New Year and Original Order 數位DP
阿新 • • 發佈:2018-12-14
Description 定義為的各個位數字從小到大排形成的數,前導忽略,求。
Sample Input 21
Sample Output 195
首先你考慮把每一種數字拆開來考慮貢獻。 然後你會發現這樣的轉移是會做到的。。。 因為你要存一個同樣的值有多少個,比他小的值有多少個才能計算貢獻。 然後就有這樣一種方法。 你可以考慮將計算答案的方式改為: 假設有j個數大於等於你現在列舉的數,那麼你對於答案的貢獻就是1111…(j個1)。 這個很好懂,你舉個例子就好了。
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
const LL mod = 1e9 + 7;
int _min(int x, int y) {return x < y ? x : y;}
int _max(int x, int y) {return x > y ? x : y;}
int read() {
int s = 0, f = 1; char ch = getchar();
while (ch < '0' || ch > '9') {if(ch == '-') f = -1; ch = getchar();}
while(ch >= '0' && ch <= '9') s = s * 10 + ch - '0', ch = getchar();
return s * f;
}
char ss[710];
int lt[710];
LL f[710][710][10][2], hh[710];
LL dfs(int x, int ov, int now, int limit) {
if(x == 0) return hh[ov];
if(f[x][ ov][now][limit] != -1) return f[x][ov][now][limit];
int up = 9; LL ans = 0;
if(limit == 1) up = lt[x];
for(int i = 0; i <= up; i++) {
int ff = limit;
if(i != up) ff = 0;
(ans += dfs(x - 1, ov + (i >= now), now, ff)) %= mod;
} f[x][ov][now][limit] = ans;
return ans;
}
int main() {
scanf("%s", ss + 1);
int len = strlen(ss + 1);
for(int i = 1; i <= len; i++) lt[len - i + 1] = ss[i] - '0';
hh[1] = 1; for(int i = 2; i <= len; i++) hh[i] = hh[i - 1] * 10LL % mod;
for(int i = 1; i <= len; i++) (hh[i] += hh[i - 1]) %= mod;
LL ans = 0;
memset(f, -1, sizeof(f));
for(int i = 1; i <= 9; i++) {
(ans += dfs(len, 0, i, 1)) %= mod;
} printf("%lld\n", ans);
return 0;
}