POJ2492 A Bug's Life
Description
Background Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. Problem
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
Sample Output
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
Source
題意:就是找出是否有同性戀的蟲子,
對於:
1 2
2 3
3 4
1 3
這是樣例的執行過程
理解:
其實這就可以理解為如果與根節點是偶數那麼就是同性 如果奇數那麼就是異性
對於 ^ 就是同性為0 異性為1;
#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdio>
#include<algorithm>
int ca = 1;
const int N = 3000;
int p[N];
int cnt[N];
int findth(int x)
{
if (x == p[x]) return x;
else {
int t = p[x];
p[x] = findth(p[x]);
cnt[x] = cnt[x] ^ cnt[t];//這個更新cnt的值,因為在並查集路徑壓縮會換父節點,所以也要更新
return p[x];
}
}
int flag = 0;
void unionn(int x, int y)
{
int xx = findth(x);
int yy = findth(y);
if (xx == yy) {
if (cnt[x] == cnt[y]) {
flag = 1;
}
return;
}
p[xx] = yy;
cnt[xx] = !(cnt[x] ^ cnt[y]);//這裡異或取反 還有就是把這個值賦值給yy的子樹的,因為剛開始賦值的都是0(cnt)
}
int main()
{
int T;
scanf("%d", &T);
while (T--) {
flag = 0;
int n, m;
scanf("%d %d", &n, &m);
for (int i = 1;i <= n;i++) {
p[i] = i;
cnt[i] = 0;
}
while (m--) {
int a, b;
scanf("%d %d", &a, &b);
unionn(a, b);
}
printf("Scenario #%d:\n", ca++);
if (flag) printf("Suspicious bugs found!\n");
else printf("No suspicious bugs found!\n");
puts("");
}
return 0;
}