1. 程式人生 > >大數加法 51Nod

大數加法 51Nod

大數加法

給出2個大整數A,B,計算A+B的結果。

Input

第1行:大數A  第2行:大數B  (A,B的長度 <= 10000 需注意:A B有可能為負數)

Output

輸出A + B

Sample Input

68932147586
468711654886

Sample Output

537643802472
import java.math.BigDecimal;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		BigDecimal a, b, c;
		Scanner shuru;
		shuru = new Scanner(System.in);
		while (shuru.hasNext()) {
			a = shuru.nextBigDecimal();
			b = shuru.nextBigDecimal();
			c = a.add(b);
			System.out.println(c);
		}
	}

}