1. 程式人生 > >02-線性結構4 Pop Sequence

02-線性結構4 Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K(the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
​#include<iostream>
#include<stack>
using namespace std ;
int main()
{
	int m,n,k;
	cin >> m >> n >> k ;
	stack<int> s;
	while(k--){
		int a[1005];
		while(!s.empty()) s.pop();
		for(int i=1;i<=n;i++) cin >> a[i] ;
		bool flag=true;int count=1;
		
		for(int i=1;i<=n;i++){
			s.push(i) ;
			if(s.size()>m) {
				flag=false;
				break;
			}
			while(!s.empty()&&s.top()==a[count]){
				s.pop();
				count++; 
			}	
		}
		
		if(s.empty()&&flag) cout << "YES"<<endl;
		else cout << "NO"<<endl;
	}
	return 0;
}

​

​