PAT 1007 Maximum Subsequence Sum(dp)
Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains Knumbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
還以為和HDU1003是一樣的,結果發現輸出完全不同。
首先輸出的區間不是下標,而是對應的值。
輸出區間要儘量靠左
如果全部為負數要特判。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<map>
#include<algorithm>
#define memset(a,v) memset(a,v,sizeof(a))
using namespace std;
typedef long long int LL;
const int MAXN(10000);
const LL INF(0x7fffffffffffffff);
LL a[MAXN+50];
int main() {
int n;
while(~scanf("%d",&n)) {
int flag=0;
for(int i=0;i<n;i++) {
scanf("%lld",a+i);
if(a[i]>=0) flag=1;
}
if(!flag) {
cout<<0<<" "<<a[0]<<" "<<a[n-1]<<endl;
continue;
}
LL sum=0,ma=-INF;
int left=0,right=0,temp=0;
for(int i=0;i<n;i++) {
sum+=a[i];
if(sum>ma) ma=sum,left=temp,right=i;
if(sum<0) sum=0,temp=i+1;
}
cout<<ma<<" "<<a[left]<<" "<<a[right]<<endl;
}
}