1. 程式人生 > >Tic Tac Toe (三連棋遊戲)

Tic Tac Toe (三連棋遊戲)

Description

Tic Tac Toe is a child's game played on a 3 by 3 grid. One player, X, starts by placing an X at an unoccupied grid position. Then the other player, O, places an O at an unoccupied grid position. Play alternates between X and O until the grid is filled or one player's symbols occupy an entire line (vertical, horizontal, or diagonal) in the grid. We will denote the initial empty Tic Tac Toe grid with nine dots. Whenever X or O plays we fill in an X or an O in the appropriate position. The example below illustrates each grid configuration from the beginning to the end of a game in which X wins.

...  X..  X.O  X.O  X.O  X.O  X.O  X.O

...  ...  ...  ...  .O.  .O.  OO.  OO.

...  ...  ...  ..X  ..X  X.X  X.X  XXX

Your job is to read a grid and to determine whether or not it could possibly be part of a valid Tic Tac Toe game. That is, is there a series of plays that can yield this grid somewhere between the start and end of the game?

Input

The first line of input contains N, the number of test cases. 4N-1 lines follow, specifying N grid configurations separated by empty lines.

Output

For each case print "yes" or "no" on a line by itself, indicating whether or not the configuration could be part of a Tic Tac Toe game.

Sample Input

2
X.O
OO.
XXX

O.X
XX.
OOO

Sample Output

yes
no

/* POJ2361 ZOJ1908 UVA10363 Tic Tac Toe */
 
#include <iostream>
#include <stdio.h>
 
using namespace std;
 
const int N = 3;
char grid[N][N + 1];
 
bool judge(char c)
{
    int j;
    for(int i = 0; i < N; i++) {
        // 按行判定
        for(j = 0; j < N && grid[i][j] == c; j++);
        if(j == N)
                return true;
        // 按列判定
        for(j = 0; j < N && grid[j][i] == c; j++);
        if(j == N)
            return true;
    }
 
    // 按邪線判定
    for(j = 0; j < N && grid[j][j] == c; j++);
    if(j == N)
        return true;
    for(j = 0; j < N && grid[j][N - 1 - j] == c; j++);
    if(j == N)
        return true;
 
    return false;
}
 
int main()
{
    int n;
    scanf("%d", &n);
    getchar();
    while(n--) {
        scanf("%s%s%s", grid[0], grid[1], grid[2]);
 
        bool flag = true;
        int xcnt = 0, ocnt = 0;
        for(int i = 0; i < N; i++)
            for(int j = 0; j < N; j++)
                if(grid[i][j] == 'X')
                    xcnt++;
                else if(grid[i][j] == 'O')
                    ocnt++;
 
        if(xcnt < ocnt || xcnt - ocnt > 1)
            flag = false;
        else {
            if(judge('O') && ocnt != xcnt)
                flag = false;
            else if(judge('X') && xcnt - ocnt != 1)
                flag = false;
        }
 
        printf("%s\n", flag ? "yes" : "no");
    }
 
    return 0;
}
 

老師程式碼比我的好,習慣性貼上上自己的程式碼

//Tic Tac Toe 
//dacao
//2018/10/22

#include<iostream>
#include<cstdio>
using namespace std;

const int N=3;
char grid[N][N+1];


bool judge(char c)
{
	int i,j;
	for(i=0;i<N;i++)//判斷行 
	{
		for(j=0;j<N;j++)
		{
			if(grid[i][j]!=c)
				break;
		}
		if(j==N)
			return true;
	}
	
	for(i=0;i<N;i++)//判斷列 
	{
		for(j=0;j<N;j++)
		{
			if(grid[j][i]!=c)
				break;
		}
		if(j==N)
			return true;
	}
	
	for(i=0;i<N;i++)//判斷左對角線 
	{
		if(grid[i][i]!=c)
			break;
	}
	if(i==N)
		return true;
		
		
	for(i=0;i<N;i++)//判斷右對角線 
	{
		if(grid[i][N-1-i]!=c)
			break;
	} 
	if(i==N)
		return true;
	
	return false;
}

int main()
{
	int n;
	bool flag;
	scanf("%d",&n);
	getchar();//接收回車 
	while(n--)
	{
		flag=true;
		scanf("%s%s%s",grid[0],grid[1],grid[2]);
		
		int xcount=0,ocount=0;
		int i,j;
		for(i=0;i<N;i++)
		{
			for(j=0;j<N;j++)
			{
				if(grid[i][j]=='X')
					xcount++;
				else if(grid[i][j]=='O')
					ocount++;
			}
		}
		
		if(xcount<ocount||xcount-ocount>1)
			 flag=false;//經過過濾之後,要麼相等,要麼xcount多一個 
		else if(judge('X')&&xcount==ocount)
			flag=false;
		else if(judge('O')&&xcount!=ocount)
			flag=false;
		
		printf("%s\n",flag ? "yes":"no");
	}
	return 0;
}