1. 程式人生 > >FZU Tic-Tac-Toe -.- FZU邀請賽 FZU 2283

FZU Tic-Tac-Toe -.- FZU邀請賽 FZU 2283

ems clas move oss out pla play accep next

Problem L Tic-Tac-Toe

Accept: 94 Submit: 184
Time Limit: 1000 mSec Memory Limit : 262144 KB

技術分享 Problem Description

Kim likes to play Tic-Tac-Toe.

Given a current state, and now Kim is going to take his next move. Please tell Kim if he can win the game in next 2 moves if both player are clever enough.

Here “next 2 moves” means Kim’s 2 move. (Kim move,opponent move, Kim move, stop).

技術分享

Game rules:

Tic-tac-toe (also known as noughts and crosses or Xs and Os) is a paper-and-pencil game for two players, X and O, who take turns marking the spaces in a 3×3 grid. The player who succeeds in placing three of their marks in a horizontal, vertical, or diagonal row wins the game.

技術分享 Input

First line contains an integer T (1 ≤ T ≤ 10), represents there are T test cases.

For each test case: Each test case contains three lines, each line three string(“o” or “x” or “.”)(All lower case letters.)

x means here is a x

o means here is a o

. means here is a blank place.

Next line a string (“o” or “x”) means Kim is (“o” or “x”) and he is going to take his next move.

技術分享 Output

For each test case:

If Kim can win in 2 steps, output “Kim win!”

Otherwise output “Cannot win!”

技術分享 Sample Input

3 . . . . . . . . . o o x o o . x x x o x o x . . o . . . x o

技術分享 Sample Output

Cannot win! Kim win! Kim win!

九宮棋Kim先下兩步之內是否可以勝利

題解下次貼

#include <iostream>  
#include <stdio.h>  
#include <algorithm>  
#include <string.h>  
#include <cmath>  
using namespace std;  
char map[4][4];  
int s[4][4],t,sum,k,cnt;  
bool judge(int x,int y){  
    if((x+y)%2==1){//當此時這個格子的行列的和為奇數時  
        cnt=0,sum=0; //cnt代表可能勝利的次數 
        for(int i=1;i<=3;i++){  
            sum+=s[i][y];  
        }  
        sum*=k;  //同是負數相乘為正數
        if(sum==2)  //空白數為2時代表可以
            return true;  
        else if(sum==1)  //當sum和為1時,此時可能勝利
            cnt++;  
        sum=0;  //註意,此時一定要重置sum,因為sum在這個函數的前面後面的含義不同
        for(int i=1;i<=3;i++){  
            sum+=s[x][i];//計算此時畫相同的符號的個數之和
        }  
        sum*=k;  
        if(sum==2)  //如果畫相同符號的和為2,代表畫下一個一定會勝利
            return true;  
        else if(sum==1)  //如果此時畫的相同的符合為1,代表可能勝利
            cnt++;  
        if(cnt==2){  //當可能勝利的次數超過2時一定可以勝利
            return true;  
        }  
    }  
    else {  //當此時這個各自的行列的和為偶數時  
        cnt=0,sum=0;  
        for(int i=1;i<=3;i++){  
            sum+=s[i][y];  
        }  
        sum*=k;  
        if(sum==2)  
            return true;  
        else if(sum==1)  
            cnt++;  
        sum=0;  
        for(int i=1;i<=3;i++){  
            sum+=s[x][i];  
        }  
        sum*=k;  
        if(sum==2)  
            return true;  
        else if(sum==1)  
            cnt++;  
        sum=0;  
        if(x==y){  //代表這個空白所在的地方在斜線上
            for(int i=1;i<=3;i++){  
                sum+=s[i][i];  
            }  
            sum*=k;  
              
            if(sum==2)  
                return true;  
            else if(sum==1)  
                cnt++;  
        }  
        else {  
            for(int i=1;i<=3;i++){  
                sum+=s[i][4-i];  
            }  
            sum*=k;  
              
            if(sum==2)  
                return true;  
            else if(sum==1)  
                cnt++;  
        }  
        if(cnt>=2){  
            return true;  
        }  
    }  
    return false;  
}  
  
int main(){  
    char st;  
    int flag;  
    scanf("%d",&t);  
    while(t--){  
        flag=0;  
        memset(s,0,sizeof(0));  
        for(int i=1;i<=3;i++){  
            for(int j=1;j<=3;j++){  
                cin>>map[i][j];  
                if(map[i][j]==.)  s[i][j]=0;  
                else if(map[i][j]==o) s[i][j]=1;  
                else if(map[i][j]==x) s[i][j]=-1;  
            }  
        }  
        cin>>st;  //代表此時Kim所用的符號
        if(st==o) k=1;  
        else if (st==x) k=-1;  
        for(int i=1;i<=3;i++){  
            for(int j=1;j<=3;j++){  
                if(map[i][j]==.){  
                    if(judge(i,j))  
                        flag=1;  
                }  
            }  
        }  
        if(flag) puts("Kim win!");  
            else    puts("Cannot win!");  
    }  
    return 0;  
}  

FZU Tic-Tac-Toe -.- FZU邀請賽 FZU 2283