1. 程式人生 > >【POJ 3134】Power Calculus

【POJ 3134】Power Calculus

【題目】

傳送門

Description

Starting with x and repeatedly multiplying by x, we can compute x31 with thirty multiplications:

x2=x×x,x3=x2×x,x4=x3×x,,x31=x30×xx^2 = x × x, x^3 = x^2 × x, x^4 = x^3 × x, …, x^{31} = x^{30} × x.

The operation of squaring can be appreciably shorten the sequence of multiplications. The following is a way to compute x31 with eight multiplications:

x2=x×x,x3=x2×x,x6=x3×x3,x7=x6×x,x14=x7×x7,x15=x14×x,x30=x15×x15,x31=x30×xx^2 = x × x, x^3 = x^2 × x, x^6 = x^3 × x^3, x^7 = x^6 × x, x^{14} = x^7 × x^7, x^{15} = x^{14} × x, x^{30} = x^{15} × x^{15}, x^{31} = x^{30} × x.

This is not the shortest sequence of multiplications to compute x31. There are many ways with only seven multiplications. The following is one of them:

x2=x×x,x4=x2×x2,x8=x4×x4,x8=x4×x4,x10=x8×x2,x20=x10×x10,x30=x20×x10,x31=x30×xx^2 = x × x, x^4 = x^2 × x^2, x^8 = x^4 × x^4, x^8 = x^4 × x^4, x^{10} = x^8 × x^2, x^{20} = x^{10} × x^{10}, x^{30} = x^{20} × x^{10}, x^{31} = x^{30} × x.

If division is also available, we can find a even shorter sequence of operations. It is possible to compute x31 with six operations (five multiplications and one division):

x2=x×x,x4=x2×x2,x8=x4×x4,x16=x8×x8,x32=x16×x16,x31=x32÷xx^2 = x × x, x^4 = x^2 × x^2, x^8 = x^4 × x^4, x^{16} = x^8 × x^8, x^{32} = x^{16} × x^{16}, x^{31} = x^{32} ÷ x.

This is one of the most efficient ways to compute x31 if a division is as fast as a multiplication.

Your mission is to write a program to find the least number of operations to compute xn by multiplication and division starting with x for the given positive integer n. Products and quotients appearing in the sequence should be x to a positive integer’s power. In others words, x−3, for example, should never appear.

Input

The input is a sequence of one or more lines each containing a single integer n. n is positive and less than or equal to 1000. The end of the input is indicated by a zero.

Output

Your program should print the least total number of multiplications and divisions required to compute xn starting with x for the integer n. The numbers should be written each in a separate line without any superfluous characters such as leading or trailing spaces.

Sample Input

1 31 70 91 473 512 811 953 0

Sample Output

0 6 8 9 11 9 13 12

【分析】

大致題意:給出 nn,詢問至少要多少次乘除可以使 xx 變成 xnx^n(不太懂的可以看題目描述,寫的很清楚)

應該是一道迭代加深的入門題吧

就是不斷地增加搜尋的深度,如果在當前深度能夠使 xx 變成 xnx^n,那最後的答案就是當前深度

注意程式碼中有一個剪枝(x<<(hdep)<nx<<(h-dep)<n),它的意思是,如果每次按最大的來取(即每次都平方)都小於 nn 的話,那肯定就不行,直接 returnreturn falsefalse

【程式碼】

#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 1005
using namespace std;
int n,h,a[N];
bool dfs(int x,int dep)
{
	if(dep>h)  return false;
	if(x==n)  return true;
	if(x<<(h-dep)<n)  return false;
	a[dep]=x;
	for(int i=0;i<=dep;++i)
	{
		if(dfs(a[i]+x,dep+1))  return true;
		if(dfs(abs(a[i]-x),dep+1))  return true;
	}
	return false;
}
int main()
{
	while(scanf("%d",&n)&&n)
	{
		h=0;
		while(!dfs(1,0))  h++;
		printf("%d\n",h);
	}
	return 0;
}