1. 程式人生 > >HDU 1009 貪心

HDU 1009 貪心

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 96673 Accepted Submission(s): 33689

Problem Description FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input 5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1

Sample Output 13.333 31.500

題目大意:一共有n個房子,每個房子裡有老鼠喜歡吃的javabeans,但是每個房間裡的javabeans的價格不一樣。老鼠用m元,問m元最多可以買多少javabeans,每個房間裡的javabeans可以被分割。直接貪。 AC程式碼:

#include<bits/stdc++.h>
typedef struct trade_s {
    //注意這裡只能是整數
    int javaBean, catFood;
    double normalize;
} trade_t;

static trade_t w[1100];

//用qsort函式必須注意這個函式返回的是int型別,所以這裡會返回1和-1
int cmp(const void * x, const void * y) {
    //注意這裡直接用減法並且返回1和-1
    return ((trade_t*)x)->normalize - ((trade_t*)y)->normalize > 0 ? -1 : 1;
}

int main() {
    //n是行數,m是總重量
    int n, m, i;
    double sum;

    while (scanf("%d %d", &m, &n)) {
        //輸入-1結束
        if (m == -1 && n == -1) break;
        //重置sum
        sum = 0;
        //輸入n行資料
        for (i = 0; i <= n - 1; i++) {
            //得到javaBean需要付出catFood
            scanf("%d %d", &w[i].javaBean, &w[i].catFood);
            //計算單價購買量
            w[i].normalize = ((double)w[i].javaBean) / w[i].catFood;
        }
        //排序
        qsort(w, n, sizeof(trade_t), cmp);

        for (i = 0; i < n; i++) {
            //如果支付得起,則購買
            if (m >= w[i].catFood) {
                //printf("food %d %d\n", w[i].catFood, w[i].javaBean);
                //增加獲得的重量
                sum = sum + w[i].javaBean;
                //減去付出
                m -= w[i].catFood;
            } else {
                //支付不起,以單價購買量乘以重量
                sum = sum + w[i].normalize * m;
                break;
            }
        }
        printf("%.3lf\n", sum);
        cout<<fixed<<setprication(3)<<sum<<endl;
    }
    return 0;
}