ACM練習 杭電oj 1880 魔咒詞典
魔咒詞典
Time Limit: 8000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 17132 Accepted Submission(s): 4054
Problem Description
哈利波特在魔法學校的必修課之一就是學習魔咒。據說魔法世界有100000種不同的魔咒,哈利很難全部記住,但是為了對抗強敵,他必須在危急時刻能夠呼叫任何一個需要的魔咒,所以他需要你的幫助。 給你一部魔咒詞典。當哈利聽到一個魔咒時,你的程式必須告訴他那個魔咒的功能;當哈利需要某個功能但不知道該用什麼魔咒時,你的程式要替他找到相應的魔咒。如果他要的魔咒不在詞典中,就輸出“what?”
Input
首先列出詞典中不超過100000條不同的魔咒詞條,每條格式為:[魔咒] 對應功能 其中“魔咒”和“對應功能”分別為長度不超過20和80的字串,字串中保證不包含字元“[”和“]”,且“]”和後面的字串之間有且僅有一個空格。詞典最後一行以“@E[email protected]”結束,這一行不屬於詞典中的詞條。 詞典之後的一行包含正整數N(<=1000),隨後是N個測試用例。每個測試用例佔一行,或者給出“[魔咒]”,或者給出“對應功能”。
Output
每個測試用例的輸出佔一行,輸出魔咒對應的功能,或者功能對應的魔咒。如果魔咒不在詞典中,就輸出“what?”
Sample Input
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@ [email protected]
4
[lumos]
the summoning charm
[arha]
take me to the sky
Sample Output
light the wand
accio
what?
what?
思路:搜map訓練題的時候發現的,某個sha博主用map做的,然後第一次用了map來存放,一直超記憶體,後來發現根本不能用map,換成兩個string陣列,過了。輸入的時候注意一下,感覺c和c++結合反正有點怪並且不高逼格,將就一下。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<string>
#include<map>
using namespace std;
string ma[100005],mb[100005];
int main()
{
char in[101];
int n;
int k = 0;
while (~scanf("%[^\n]s",in))
{
getchar();
if (strcmp(in, "@[email protected]") == 0)
{
break;
}
int flag = 1;
for (int i = 0; i < strlen(in); i++)
{
if (in[i] != ']'&&flag)
{
ma[k] += in[i];
}
else if(in[i] == ']')
{
ma[k] += in[i];
flag = 0;
continue;
}
else if(in[i-1]==']')
{
continue;
}
else
{
mb[k] += in[i];
}
}
k++;
}
scanf("%d", &n);
getchar();
char tt[101];
for (int i = 0; i < n; i++)
{
scanf("%[^\n]s", tt);
getchar();
if (tt[0] != '[')
{
int flag = 0;
for (int j = 0; j< k; j++)
{
if (mb[j] == tt)
{
int len = ma[j].length();
printf("%s\n", ma[j].substr(1, len - 2).c_str());
flag = 1;
break;
}
}
if (!flag)
{
printf("what?\n");
}
}
else
{
int flag = 0;
for (int j = 0; j< k; j++)
{
if (ma[j] == tt)
{
printf("%s\n", mb[j].c_str());
flag = 1;
break;
}
}
if (!flag)
{
printf("what?\n");
}
}
}
return 0;
}