1. 程式人生 > >1027 Colors in Mars(20)

1027 Colors in Mars(20)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0

 to its left.

Sample Input:

15 43 71

Sample Output:

#123456
#include<iostream>
using namespace std;
void cmp1(int a)
{
	if (a < 10)
		cout << a;
	else
	{
		if (a == 10)
			cout << "A";
		if (a == 11)
			cout << "B";
		if (a == 12)
			cout << "C";
	}
}
void cmp(int n, int a)
{
	if (n < 13)
	{
		if (n < 10)
			cout << "0" << n;
		else
		{
			if (n == 10)
				cout << "0A";
			if (n == 11)
				cout << "0B";
			if (n == 12)
				cout << "0C";
		}
	}
	else
	{
		int x, y;
		x = n%a;
		n = n / a;
		y = n%a;
		cmp1(y);
		cmp1(x);
	}
	
}
int main()
{
	int a, b, c;
	cin >> a >> b >> c;
	cout << "#";
	cmp(a,13);
	cmp(b,13);
	cmp(c,13);
	return 0;
}