PAT甲級 1044 Shopping in Mars(二分查詢)
1044 Shopping in Mars (25 分)
Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:
- Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
- Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
- Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.
If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1⋯DN (Di≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print i-j
in a line for each pair of i
≤ j
such that Di
+ ... + Dj
= M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i
.
If there is no solution, output i-j
for pairs of i
≤ j
such that Di
+ ... + Dj
>M with (Di
+ ... + Dj
−M) minimized. Again all the solutions must be printed in increasing order of i
.
It is guaranteed that the total value of diamonds is sufficient to pay the given amount.
Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5
//題目大意:給你n個數,讓你找出和為m的子序列,若有多個這樣的子序列,按子序列起始點i從小到大依次輸出 ,若沒有該子序列,則找出和大於且最接近m的子序列,若有多個滿足條件的子序列,則按上述規則輸出;
//思路:sum[i]表示從第一個數到第i個數的和,由於sum[i]是遞增的,所以可以用二分查詢找到>=m的子序列;
//原因:沒思路;
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
struct Node
{
int x,y;
};
vector<Node>ans;
int main()
{
int n,m;
scanf("%d%d",&n,&m);
int sum[100005];
sum[0]=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&sum[i]);
sum[i]+=sum[i-1];
}
int minn=0x3f3f3f3f;
for(int i=1;i<=n;i++)
{
int low=i,high=n,mid;
while(low<=high)
{
mid=(low+high)/2;
if(sum[mid]-sum[i-1]<m)
low=mid+1;
else
high=mid-1;
}
if(sum[low]-sum[i-1]>=m)
{
if(sum[low]-sum[i-1]<minn)
{
minn=sum[low]-sum[i-1];
ans.clear();
Node node;
node.x=i;node.y=low;
ans.push_back(node);
}else if(sum[low]-sum[i-1]==minn)
{
Node node;
node.x=i;node.y=low;
ans.push_back(node);
}
}
}
for(int i=0;i<ans.size();i++)
{
printf("%d-%d\n",ans[i].x,ans[i].y);
}
return 0;
}