1. 程式人生 > >POJ 1789-Truck History

POJ 1789-Truck History

Truck History
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 31951Accepted: 12464

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to
,td)
d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

題意:

就是在很久以前,卡車的型號是很單一的,七個字元組成的字串來表示卡車的型號,隨著科技的發展,現在卡車的型號改變了,但新的型號也是在舊的型號的基礎之上改變的,現在定義一個改變的原則,就是規定兩個卡車的更新距離就是兩個卡車的型號不相同的字元個數,這裡比較是按照對應位置上的字元,例如 abaaaaa 和 aabaaaa ,這兩個卡車的更新距離是 2 ,因為有兩個位置上的字元不相同,讓你計算出所有卡車之間最小的更新距離 Q,輸出 The highest possible quality is 1/Q.

分析:

本題真的是讀題半小時還是讀的模模糊糊的,英文水平有待提高哇!

最小生成樹的變形,假設將每輛卡車都進行一個編號,將兩個卡車對應位置上的字母不相同的個數作為他們之間的權值,是不是求出最小生成樹,就能就出 Q 的最優解了。

#include <iostream>
#include<stdio.h>
#include<math.h>
#include<string>
#include<string.h>
using namespace std;
#define INF 0x3f3f3f3f
int s[2005][2005];
int n;

void Prim()
{
    int vis[2005],low[2005],minx,bj;
    int sum=0;
    for(int i=1;i<=n;i++)
        low[i]=s[1][i];
    memset(vis,0,sizeof(vis));
    vis[1]=1;
    for(int i=1;i<n;i++)
    {
        minx=INF;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&minx>low[j])
            {
                bj=j;
                minx=low[j];
            }
        }
        vis[bj]=1;
        sum+=minx;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&low[j]>s[bj][j])
                low[j]=s[bj][j];
        }
    }
    printf("The highest possible quality is 1/%d.\n",sum);
}

int main()
{
   char h1[2005][10];
   while(~scanf("%d",&n)&&n)
   {
       getchar();///注意這裡要吞掉回車
       for(int i=0;i<=n;i++)
       {
           for(int j=0;j<=n;j++)
           {
               if(i==j)
                    s[i][j]=0;
               else
                s[i][j]=INF;
           }
       }
       for(int i=1;i<=n;i++)
       {
            gets(h1[i]);///輸入卡車的型號
            for(int j=1;j<i;j++)///進行權值的計算,存圖
            {
                int sum=0;
                for(int k=0;k<7;k++)
                {
                    if(h1[j][k]!=h1[i][k])
                        sum++;
                }
                s[i][j]=s[j][i]=min(s[i][j],sum);
            }
       }
       Prim();
   }
    return 0;
}