1. 程式人生 > >poj 1789(最小生成樹)

poj 1789(最小生成樹)

Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11665 Accepted: 4376

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to
,td)
d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

題目型別:最小生成樹 題目描述:每種型別卡車由7位小寫字母組成。卡車的進化歷史,都是從一種卡車,衍生出一種新卡車。 求1/Q的最大值,也就是求Q的最小值。Q為N種卡車進化所需的權值和。從一種卡車進化成另一種卡車的權值為,7位代號,相同位 不同字母的數量。 題目分析:可以抽象成,一種卡車演化成另一個種卡車。相當於兩個節點之間有一條邊。 求Q的最小值,相當於求把所有卡車連通在一起需要的最小費用。即最小生成樹問題。 程式碼如下:
#include <iostream>
#include <stdio.h>
#include <algorithm>
#define V 2001
#define E V * (V-1) / 2
using namespace std;
int n,k;
char trucks[V][8];
int f[V];
int rank[V];
struct Edge{
    int u,v,w;
};
Edge edge[E];

bool cmp(Edge a,Edge b){
    if(a.w < b.w){
        return true;
    } else {
        return false;
    }
}

void createEdge(char a[],char b[],int u,int v) {
    int sum = 0;
    for(int i = 0; i < 8; i++){
        if(a[i] != b[i]) {
            sum++;
        }
    }
    k++;
    edge[k].u = u;
    edge[k].v = v;
    edge[k].w = sum;

}

void makeSet(){
    for (int i = 0; i < n; i++){
        f[i] = i;
        rank[i] = 0;
    }
}

int findRoot(int x){
    if( x == f[x]){
        return x;
    } else {
        return f[x] = findRoot(f[x]);
    }
}

void merge(int a,int b){
    int ra = findRoot(a);
    int rb = findRoot(b);
    if(ra != rb){
        if(rank[ra] < rank[rb]){
            f[ra] = rb;
        } else {
            f[rb] = ra;
            if(rank[ra] == rank[rb]){
                rank[ra]++;
            }
        }
    }
}

int main()
{
    while(scanf("%d",&n),n){
        int sum = 0;
        k = -1;
        getchar();
        for(int i = 0; i < n; i++){
            gets(trucks[i]);
            for(int j = 0; j < i; j++){
                createEdge(trucks[i],trucks[j],i,j);
            }
        }
        makeSet();
        sort(edge,edge+k+1,cmp);
        for(int i = 0; i <= k ; i++){
            int ru = findRoot(edge[i].u);
            int rv = findRoot(edge[i].v);
            if(ru != rv){
                sum += edge[i].w;
                merge(edge[i].u,edge[i].v);
            }
        }
        printf("The highest possible quality is 1/%d.\n",sum);
    }

    return 0;
}