1. 程式人生 > >浙大 PAT 甲級1009

浙大 PAT 甲級1009

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi

 (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 3 3.6 2 6.0 1 1.6

#include<stdio.h>
int main(){
	double a[1001]={0.0},b[2001]={0.0},t;  //開兩個陣列,前一個存第一個多項式,下標為次數,值為係數, 後一個要大一些防止越界,並且直接儲存結果。 
	int  n1,n2,m,n,i,j;
	scanf("%d",&n1);
	for(i=0;i<n1;i++){
		scanf("%d %lf",&m,&t);
		a[m]=t;
	}
	scanf("%d",&n2);
	for(i=0;i<n2;i++){
		scanf("%d %lf",&m,&t);
		for(j=0;j<1001;j++){
			if(a[j]!=0.0){
				b[m+j]+=a[j]*t;           //這裡就是模擬多項式乘法的關鍵!! 
			}
		}
	}
	j=0;
	for(i=0;i<2001;i++){
		if(b[i]!=0.0)
			j++;
	}
	printf("%d",j);
	for(i=2000;i>=0;i--){
		if(b[i]!=0.0)
			printf(" %d %.1lf",i,b[i]);
	}
	return 0;
}