1. 程式人生 > >ALDS1_5_A Exhaustive Search 窮竭搜尋

ALDS1_5_A Exhaustive Search 窮竭搜尋

Write a program which reads a sequence A of n elements and an integer M, and outputs "yes" if you can make M by adding elements in A, otherwise "no". You can use an element only once.

You are given the sequence A and q questions where each question contains Mi.

Input

In the first line n is given. In the second line, n

integers are given. In the third line q is given. Then, in the fourth line, q integers (Mi) are given.

Output

For each question Mi, print yes or no.

Constraints

  • n ≤ 20
  • q ≤ 200
  • 1 ≤ elements in A ≤ 2000
  • 1 ≤ Mi ≤ 2000

Sample Input 1

5
1 5 7 10 21
8
2 4 17 8 22 21 100 35

Sample Output 1

no
no
yes
yes
yes
yes
no
no

Notes

You can solve this problem by a Burte Force approach. Suppose solve(p, t) is a function which checkes whether you can make t by selecting elements after p-th element (inclusive). Then you can recursively call the following functions:

solve(0, M)
solve(1, M-{sum created from elements before 1st element})
solve(2, M-{sum created from elements before 2nd element})
...

The recursive function has two choices: you selected p-th element and not. So, you can check solve(p+1, t-A[p]) and solve(p+1, t) in solve(p, t) to check the all combinations.

For example, the following figure shows that 8 can be made by A[0] + A[2].

程式碼如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=25;
int n,q;
int a[maxn];
int flag;
int x;
void cho (int loc,int sum)
{
    if(sum==x)
    {
        flag=1;
        return;
    }
    if(loc>n)
        return;
    cho (loc+1,sum);
    cho (loc+1,sum+a[loc]);
}
void input ()
{
    scanf("%d",&n);
    for (int i=1;i<=n;i++)
        scanf("%d",&a[i]);
    scanf("%d",&q);
    while (q--)
    {
        scanf("%d",&x);
        flag=0;
        cho (1,0);
        if(flag)
            printf("yes\n");
        else
            printf("no\n");
    }
}
int main()
{
    input();
    return 0;
}